Monday, 31 July 2017

How To Install Metasploit In Android Using Termux Without Root

87 comments
Hello Guys , Welcome To Hax4Us
        ****************************************



Dosto aaj hum apne android mobile me Metasploit ko install karenge Vo bhi...Without Root...Yes...It Is possible...

Just Follow My Steps...
***************************



  1. Install Termux App From Playstore
  2. Open App & Wait While Installing
  3. Hit the command :-> apt update && apt upgrade
  4. Then Enter or copy the command :- apt install curl
  5. Enter or copy the command :- curl -LO https://raw.githubusercontent.com/Hax4us/Metasploit_termux/master/metasploit.sh
  6. Now give permission by :- chmod +x metasploit.sh
  7. Now execute :- ./metasploit.sh
  8. And now wait until processing and downloading ...it can take upto 40 minutes.. Well..depend upon internet speed...
Note :- Koi bhi problem aane pe aap mujse comment box me ya telegram group me pooch skte hai :)
If You Enjoyed This, Take 5 Seconds To Share It

87 comments:

  1. when i type msfconsole framework is not startinng that saying requires gem bundler plz fix it email-shan.sm10@gmail.com

    ReplyDelete
    Replies
    1. when i type msfconsole framework is not startinng that saying requires gem bundler plz fix it

      Delete
    2. I think you have to install the gem bundler from bash separately. It happens sometimes that the chain commands doesn't work in android kernels without superuser access.

      Delete
    3. Help me

      [!] There was an error parsing `Gemfile`:
      [!] There was an error while loading `grpc.gemspec`: cannot load such file -- grpc/version
      Does it try to require a relative path? That's been removed in Ruby 1.9. Bundler cannot continue.

      # from /data/data/com.termux/files/home/metasploit-framework/grpc.gemspec:4
      # -------------------------------------------
      # $LOAD_PATH.push File.expand_path('../src/ruby/lib', __FILE__)
      > require 'grpc/version'
      #
      # -------------------------------------------
      . Bundler cannot continue.

      # from /data/data/com.termux/files/home/metasploit-framework/Gemfile:4
      # ------------------------------------------. Bundler cannot continue.

      # from /data/data/com.termux/files/home/metasploit-framework/Gemfile:4
      # -------------------------------------------
      # # spec.add_runtime_dependency '', []
      > gemspec name: 'metasploit-framework'
      #
      # -------------------------------------------

      Delete
    4. Help me my no is 9370695934
      [!] There was an error parsing `Gemfile`:
      [!] There was an error while loading `grpc.gemspec`: cannot load such file -- grpc/version
      Does it try to require a relative path? That's been removed in Ruby 1.9. Bundler cannot continue.

      # from /data/data/com.termux/files/home/metasploit-framework/grpc.gemspec:4
      # -------------------------------------------
      # $LOAD_PATH.push File.expand_path('../src/ruby/lib', __FILE__)
      > require 'grpc/version'
      #
      # -------------------------------------------
      . Bundler cannot continue.

      # from /data/data/com.termux/files/home/metasploit-framework/Gemfile:4
      # ------------------------------------------. Bundler cannot continue.

      # from /data/data/com.termux/files/home/metasploit-framework/Gemfile:4
      # -------------------------------------------
      # # spec.add_runtime_dependency '', []
      > gemspec name: 'metasploit-framework'
      #
      # -------------------------------------------

      Delete
  2. need to upgrade bundler and could not locate to 1.16.0.pre.3 .Help me fix it mailing to whitedemo.mt@gmail.com

    ReplyDelete
    Replies
    1. reinstall termux then try again ....in case of any error u can ask

      Delete
    2. Sir can you please help me ?
      My whatsapp or telegram no. Is 9722416843

      Delete
  3. Metasploit run nahi ho raha hai
    An error occurred while installing
    nokogiri (1.8.0), and Bundler cannot continue.
    Make sure that `gem install nokogiri -v '1.8.0'`
    succeeds before bundling

    ReplyDelete
    Replies
    1. Goto metasploit folder
      Then enter :- gem install nokogiri -v 1.8.0 -- --used systems libraries

      Then enter :- bundle install -j5

      Delete
  4. Payload nehi banrahahe permission denied arahahe
    Plzzz help

    ReplyDelete
    Replies
    1. Enter one by one
      apt install termux-api
      termux-setup-storage
      Now u can create Payload..

      Delete
    2. 1: from /data/data/com.termux/files/usr/lib/ruby/2.6.0/bigdecimal/util.rb:9:in `'
      /data/data/com.termux/files/usr/lib/ruby/2.6.0/bigdecimal/util.rb:9:in `require': dlopen failed: cannot locate symbol "rmpd_util_str_to_d" referenced by "/data/data/com.termux/files/usr/lib/ruby/2.6.0/aarch64-linux-android/bigdecimal/util.so"... - /data/data/com.termux/files/usr/lib/ruby/2.6.0/aarch64-linux-android/bigdecimal/util.so (LoadError, plz give me reply, apke method se he kya h metasploit install but erroe araha h

      Delete
  5. . This is on account of the greater part of the applications and games accessible in the App Store are premium and clients need to pay to download and utilize them. How to Hack Summoners War

    ReplyDelete
  6. Replies
    1. Please can you help me or give any point. When i try to run metasploit methods it says that he can locate gemfile or nokogiri 1.8,0 ! And that's stop me always with another answer like soory unreleased not pubkey 62787... Not available!? What should I do?

      Delete
  7. When I type cd metasploit-framework-4.14.28
    and press enter i get a message saying:-
    bash: cd: metasploit-framework-4.14.28: No such files or directory
    plz help

    ReplyDelete
    Replies
    1. Bro now script is updated u have to :- cd metasploit-framework
      Not cd metasploit-framework-4.14.28

      Delete
  8. The GitHub link of metasploit is having malicious

    ReplyDelete
  9. Bhai just tell me one thing how did you learn all these things exactly?

    ReplyDelete
  10. When i type msfconsole at the last it says no such file or directory. What should i do.

    ReplyDelete
    Replies
    1. even i dint get msfconsole in metasploit framework

      Delete
  11. bhai lokesh metasploit ko pehle download krna pdega kua apne file manager me or export bi krna pdega kya ?

    ReplyDelete
  12. This script tacking my personal storage data

    ReplyDelete
    Replies
    1. Try and reply me.

      server started
      ###############################
      Thanx To Vishalbiswani
      ###############################
      ###############################################
      Hello I Am Devil (Lokesh) , Subscribe My Channel To Motivate My Work
      ###############################################
      ###############################
      For More. Tricks. Visit At hax4us.com
      ###############################
      ####################################
      NOW YOU CAN LAUNCH METASPLOIT BY JUST EXECUTE THE COMMAND :=> msfconsole
      ####################################

      When I type msfconsole nothing happens

      Delete
    2. When I type msfconsole, it Say's Command not find

      Delete
  13. Lokesh Bhai Termux ki Use Kerka Link generat ker sakte hai kya Hack kerna ki liye

    ReplyDelete
  14. Nokogiri 1.8.0 not installed
    Plz help

    ReplyDelete
  15. is postgresql required to run metasploit-framework ??

    ReplyDelete
  16. Thq bro....how to install wifite on termux pls help bro

    ReplyDelete
  17. This comment has been removed by the author.

    ReplyDelete
  18. This comment has been removed by the author.

    ReplyDelete
  19. Finally i got in contact with cyberhackpros@gmail.com they helped me hack into my spouse facebook smoothly, hacked into her emails and cell phone.the sweetest of all is that they are fast and quick which helped during my Divorce. mentioning my name would make him respond and treat you better as we are now close. Just tell him you are from me,stacey . He also does so many other hacks like facebook, whatsapp, bank, credit card,paypal,skype,Snapchat,Calls… just name it or call/text +1 512 605 1256

    ReplyDelete
  20. After typing msfconsole it says permission denied what to do

    ReplyDelete
  21. "Downloading nokogiri-1.8.0 revealed dependencies
    not in the API or the lockfile (mini_portile2 (~>
    2.2.0)).
    Either installing with `--full-index` or running
    `bundle update nokogiri` should fix the problem.

    In Gemfile:
    factory_girl_rails was resolved to 4.9.0, which
    depends on
    railties was resolved to 4.2.10, which depends
    on
    actionpack was resolved to 4.2.10, which
    depends on
    actionview was resolved to 4.2.10, which
    depends on
    rails-dom-testing was resolved to 1.0.8,
    which depends on
    nokogiri"

    Thats the problem what should i do?

    ReplyDelete
  22. !] There was an error parsing `Gemfile`:
    [!] There was an error while loading `grpc.gemspec`: cannot load such file -- grpc/version
    Does it try to require a relative path? That's been removed in Ruby 1.9. Bundler cannot continue.

    # from /data/data/com.termux/files/home/metasploit-framework/grpc.gemspec:4
    # -------------------------------------------
    # $LOAD_PATH.push File.expand_path('../src/ruby/lib', __FILE__)
    > require 'grpc/version'
    #
    # -------------------------------------------
    . Bundler cannot continue.

    # from /data/data/com.termux/files/home/metasploit-framework/Gemfile:4
    # -------------------------------------------
    # # spec.add_runtime_dependency '', []
    > gemspec name: 'metasploit-framework'
    #
    # -------------------------------------------
    What i do

    ReplyDelete
  23. Keya proble hai ye
    #msfconsole
    Your lockfile is unreadable. Run `rm Gemfile.lock` and then `bundle install` to generate a new lockfile. $

    ReplyDelete
  24. This isn't working man ! ���
    At first it shows "Downloading nokogiri-1.8.0 revealed dependencies not in the API or the lockfile
    (mini_portile2 (~> 2.2.0)).
    Either installing with `--full-index` or running `bundle update nokogiri` should
    fix the problem.

    In Gemfile:
    factory_girl_rails was resolved to 4.9.0, which depends on
    railties was resolved to 4.2.10, which depends on
    actionpack was resolved to 4.2.10, which depends on
    actionview was resolved to 4.2.10, which depends on
    rails-dom-testing was resolved to 1.0.8, which depends on
    nokogiri"
    Then it says "waiting for server to start....2018-05-13 17:37:48.704 BDT [5135] LOG: listening on IPv4 address "127.0.0.1", port 5432
    2018-05-13 17:37:48.715 BDT [5135] LOG: listening on Unix socket "/data/data/com.termux/files/usr/tmp/.s.PGSQL.5432"
    2018-05-13 17:37:48.789 BDT [5139] LOG: database system was shut down at 2018-05-13 17:37:48 BDT
    2018-05-13 17:37:48.833 BDT [5135] LOG: database system is ready to accept connections
    done
    server started
    ###############################
    Thanx To Vishalbiswani
    ###############################
    ###############################################
    Hello I Am Devil (Lokesh) , Subscribe My Channel To Motivate My Work
    ###############################################
    ###############################
    For More. Tricks. Visit At hax4us.com
    ###############################
    ####################################
    NOW YOU CAN LAUNCH METASPLOIT BY JUST EXECUTE THE COMMAND :=> msfconsole
    ####################################
    $ msfconsole
    Could not find nokogiri-1.8.0 in any of the sources
    Run `bundle install` to install missing gems."


    **HELP ME Lokesh vai**��

    ReplyDelete
  25. Same here...


    #HELP please !!!

    #H E L P#

    ReplyDelete
  26. great superb post bro i am using your github Metasploit url in my blogger if you have any issue the reply me Thanks
    This is the link of my post
    http://vijayhow.blogspot.com/2018/05/HOW-TO-INSTALL-METASPLOIT-IN-ANDROID-USING-TERMUX-WITHOUT-ROOT.html

    ReplyDelete
  27. Can you sand me your whatsapp number.

    ReplyDelete
  28. PLIZZZ HELP !!!!! I do not know what to do, download gem file manually, the result 0
    $ msfconsole
    Traceback (most recent call last):
    24: from /data/data/com.termux/files/usr/bin/msfconsole:47:in `'
    23: from /data/data/com.termux/files/usr/bin/msfconsole:47:in `require'
    22: from /data/data/com.termux/files/home/metasploit-framework/lib/msf/core/payload_generator.rb:2:in `'
    21: from /data/data/com.termux/files/home/metasploit-framework/lib/msf/core/payload_generator.rb:2:in `require'
    20: from /data/data/com.termux/files/home/metasploit-framework/lib/msf/core/payload/apk.rb:3:in `'
    19: from /data/data/com.termux/files/home/metasploit-framework/lib/msf/core/payload/apk.rb:3:in `require'
    18: from /data/data/com.termux/files/home/metasploit-framework/lib/msf/core.rb:18:in `'
    17: from /data/data/com.termux/files/usr/lib/ruby/gems/2.5.0/gems/backports-3.10.3/lib/backports/std_lib.rb:9:in `require_with_backports'
    16: from /data/data/com.termux/files/usr/lib/ruby/gems/2.5.0/gems/backports-3.10.3/lib/backports/std_lib.rb:9:in `require'
    15: from /data/data/com.termux/files/home/metasploit-framework/lib/rex.rb:100:in `'
    14: from /data/data/com.termux/files/usr/lib/ruby/gems/2.5.0/gems/backports-3.10.3/lib/backports/std_lib.rb:9:in `require_with_backports'
    13: from /data/data/com.termux/files/usr/lib/ruby/gems/2.5.0/gems/backports-3.10.3/lib/backports/std_lib.rb:9:in `require'
    12: from /data/data/com.termux/files/home/metasploit-framework/lib/rex/proto.rb:2:in `'
    11: from /data/data/com.termux/files/usr/lib/ruby/gems/2.5.0/gems/backports-3.10.3/lib/backports/std_lib.rb:9:in `require_with_backports'
    10: from /data/data/com.termux/files/usr/lib/ruby/gems/2.5.0/gems/backports-3.10.3/lib/backports/std_lib.rb:9:in `require'
    9: from /data/data/com.termux/files/home/metasploit-framework/lib/rex/proto/http.rb:4:in `'
    8: from /data/data/com.termux/files/usr/lib/ruby/gems/2.5.0/gems/backports-3.10.3/lib/backports/std_lib.rb:9:in `require_with_backports'
    7: from /data/data/com.termux/files/usr/lib/ruby/gems/2.5.0/gems/backports-3.10.3/lib/backports/std_lib.rb:9:in `require'
    6: from /data/data/com.termux/files/home/metasploit-framework/lib/rex/proto/http/response.rb:4:in `'
    5: from /data/data/com.termux/files/usr/lib/ruby/gems/2.5.0/gems/backports-3.10.3/lib/backports/std_lib.rb:9:in `require_with_backports'
    4: from /data/data/com.termux/files/usr/lib/ruby/gems/2.5.0/gems/backports-3.10.3/lib/backports/std_lib.rb:9:in `require'
    3: from /data/data/com.termux/files/usr/lib/ruby/gems/2.5.0/gems/nokogiri-1.8.0/lib/nokogiri.rb:28:in `'
    2: from /data/data/com.termux/files/usr/lib/ruby/gems/2.5.0/gems/nokogiri-1.8.0/lib/nokogiri.rb:32:in `rescue in '
    1: from /data/data/com.termux/files/usr/lib/ruby/gems/2.5.0/gems/backports-3.10.3/lib/backports/std_lib.rb:9:in `require_with_backports'
    /data/data/com.termux/files/usr/lib/ruby/gems/2.5.0/gems/backports-3.10.3/lib/backports/std_lib.rb:9:in `require': dlopen failed: "/data/data/com.termux/files/usr/lib/ruby/gems/2.5.0/gems/nokogiri-1.8.0/lib/nokogiri/nokogiri.so" is too small to be an ELF executable: only found 0 bytes - /data/data/com.termux/files/usr/lib/ruby/gems/2.5.0/gems/nokogiri-1.8.0/lib/nokogiri/nokogiri.so (LoadError)



    ReplyDelete
  29. Bhai mfsconsole framework karne par command not found bta raha

    ReplyDelete
  30. there was an error while loding grpc.gemsp

    ReplyDelete
  31. this is the error that is prompting on my mobile screen

    ReplyDelete
  32. 99 25.4M 99 25.4M 0 0 16415 0 0:27:05 99 25.4M 99 25.4M 0 0 16413 0 0:27:05 99 25.4M 99 25.4M 0 0 16410 0 0:27:05 100 25.4M 100 25.4M 0 0 16411 0 0:27:05 0:27:05 --:--:-- 16690
    ./metasploit.sh: line 26: gem: command not found
    ./metasploit.sh: line 28: gem: command not found
    ./metasploit.sh: line 32: [: ==: unary operator expected
    nokogiri already installed
    ./metasploit.sh: line 40: bundle: command not found
    Gems installed
    ./metasploit.sh: line 43: /data/data/com.termux/files/usr/bin/find: No such file or directory
    ln: /data/data/com.termux/files/usr/bin/msfconsole: File exists
    ln: /data/data/com.termux/files/usr/bin/msfvenom: File exists
    ./metasploit.sh: line 55: termux-elf-cleaner: command not found
    Creating database
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    0 0 0 0 0 0 0 0 --:--:-- - 0 0 0 0 0 0 0 0 --:--:-- -100 162 100 162 0 0 97 0 0:00:01 100 162 100 162 0 0 97 0 0:00:01 0:00:01 --:--:-- 97
    ./metasploit.sh: line 64: initdb: command not found
    ./metasploit.sh: line 66: pg_ctl: command not found
    ./metasploit.sh: line 67: createuser: command not found
    ./metasploit.sh: line 68: createdb: command not found
    you can directly use msfvenom or msfconsole rather than ./msfvenom or ./msfconsole.


    ÷÷÷÷÷÷÷÷÷÷÷÷÷÷÷÷÷÷÷÷÷÷÷÷÷÷÷÷÷÷÷÷÷÷÷÷÷÷÷
    Sir . Is ke agay nahi ja paraha hu. Kea karu plzzz help me

    ReplyDelete
  33. msfconsole metasploittechnoash+%282%29.sh
    msfconsole: command not found
    $ ./msfconsole metasploittechnoash+%282%29.sh
    bash: ./msfconsole: No such file or directory

    ReplyDelete
  34. Enter your comment...ch metasploit-framework....no such file or directory
    pls help me fix it
    my email is...ibnhaajii@gmail.com

    ReplyDelete
  35. please help me give solution for this error

    WARNING: linker: nokogiri.so: unused DT entry: type 0x6ffffef5 arg 0xb1c
    WARNING: linker: pcaprub_c.so: unused DT entry: type 0x6ffffef5 arg 0x36c
    WARNING: linker: bcrypt_ext.so: unused DT entry: type 0x6ffffef5 arg 0x25c
    WARNING: linker: msgpack.so: unused DT entry: type 0x6ffffef5 arg 0x60c
    WARNING: linker: redcarpet.so: unused DT entry: type 0x6ffffef5 arg 0x2b4
    WARNING: linker: pg_array_parser.so: unused DT entry: type 0x6ffffef5 arg 0x1b4
    WARNING: linker: pg_ext.so: unused DT entry: type 0x1d arg 0x1682
    WARNING: linker: pg_ext.so: unused DT entry: type 0x6ffffef5 arg 0xb4c
    [-] Failed to connect to the database: could not connect to server: Connection refused
    Is the server running on host "127.0.0.1" and accepting
    TCP/IP connections on port 5432?

    WARNING: linker: network_interface_ext.so: unused DT entry: type 0x6ffffef5 arg 0x1f4
    WARNING: linker: sqlite3_native.so: unused DT entry: type 0x6ffffef5 arg 0x5a0

    ReplyDelete
  36. I figured I would toss a few watchwords that might depict what I want to do. In the event that you perceive yourself in some of them, I figure it may be worth requiring the investment to continue perusing my profile. On the off chance that you don't continue understanding, I swear I won't be angry with you. I will never know in any case
    Health Blog

    ReplyDelete
  37. bhai nokogiri gem install nahi howa us k bina start nahi hoga kya karrooo may ab

    ReplyDelete
  38. Its showing msfconsole no such command or directory

    ReplyDelete
  39. [!] There was an error parsing `Gemfile`:
    [!] There was an error while loading `grpc.gemspec`: cannot load such file -- grpc/version
    Does it try to require a relative path? That's been removed in Ruby 1.9. Bundler cannot continue.

    # from /data/data/com.termux/files/home/metasploit-framework/grpc.gemspec:4
    # -------------------------------------------
    # $LOAD_PATH.push File.expand_path('../src/ruby/lib', __FILE__)
    > require 'grpc/version'
    #
    # -------------------------------------------
    . Bundler cannot continue.

    # from /data/data/com.termux/files/home/metasploit-framework/Gemfile:4
    # -------------------------------------------
    # # spec.add_runtime_dependency '', []
    > gemspec name: 'metasploit-framework'
    #
    # ------------------------------------------
    i have a problem
    it is not solve

    ReplyDelete
  40. I have a probelm not paste in termux link will be copy

    ReplyDelete
  41. Msfvenom command not found !!


    Plz tell solution fast !!

    ReplyDelete
  42. Successfully installed bundler-2.0.1
    1 gem installed
    $ msfconsole
    [*] Metasploit requires the Bundler gem to be installed
    $ gem install bundler

    ReplyDelete
  43. Successfully installed bundler-2.0.1
    1 gem installed
    $ msfconsole
    [*] Metasploit requires the Bundler gem to be installed
    $ gem install bundler


    Pls help me solve this problem

    Plllsss

    ReplyDelete
  44. Traceback (most recent call last):
    ruby: No such file or directory -- /data/data/com.termux/files/home/metasploit-framework/msfconsole (LoadError)...help me

    ReplyDelete
  45. ERROR: While executing gem ... (Errno::EINVAL)
    Invalid argument - send(2)
    ERROR: While executing gem ... (Errno::EINVAL)
    Invalid argument - send(2)
    ERROR: While executing gem ... (Errno::EINVAL)
    Invalid argument - send(2)
    ./metasploit.sh: line 41: bundle: command not found
    Gems installed

    ReplyDelete
  46. My husband was so smooth at hiding her infidelity and I had no proof for months, I saw a recommendation about a Private investigator and decided to give him a try.. the result was incredible because all my cheating husbands text messages, whatsapp, facebook and his phone conversations was sent directly to my Personal computer. Mr James helped me put a round-the-clock monitoring on him and I got concrete evidence and gave it to my lawyer..I say no to infidelity if your husband is an expert at hiding his cheating adventures contact him through Gmail he will help you(Worldcyberhackers) or WhatsApp : +12678773020

    ReplyDelete
  47. Bro i installed metasploit framework successfully without any errors but when i opened msfconsole then i got error yr. Plz help me bro


    See i got this error :

    $ cd metasploit-framework
    $ ./msfconsole
    metasploit-credential not in the bundle, so Metasploit::Credential creation will fail for Msf::DBManager
    Traceback (most recent call last):
    36: from ./msfconsole:48:in `'
    35: from ./msfconsole:48:in `require'
    34: from /data/data/com.termux/files/home/metasploit-framework/lib/msf/core/payload_generator.rb:2:in `'
    20: from /data/data/com.termux/files/home/metasploit-framework/lib/metasploit/framework/require.rb:115:in `optionally_include_metasploit_credential_creation'
    17: from /data/data/com.termux/files/usr/lib/ruby/gems/2.6.0/gems/backports/data/data/com.termux/files/usr/lib/ruby/gems/2.6.0/gems/backports-3.11.4/lib/backports/std_lib.rb:9:in `require_with_backports'
    13: from /data/data/com.termux/files/usr/lib/ruby/gems/2.6.0/gems/backports-3.11.4/lib/backports/std_lib.rb:9:in `require'
    12: from /data/data/com.termux/files/usr/lib/ruby/gems/2.6.0/gems/metasploit_data_models-2.0.16/lib/metasploit_data_models.rb:15:in `'
    11: from /data/data/com.termux/files/usr/lib/ruby/gems/2.6.0/gems/backports-3.11.4/lib/backports/std_lib.rb:9:in `require_with_backports'
    10: from /data/data/com.termux/files/usr/lib/ruby/gems/2.6.0/gems/backports-3.11.4/lib/backports/std_lib.rb:9:in `require'
    5: from /data/data/com.termux/files/usr/lib/ruby/gems/2.6.0/gems/activerecord-4.2.11/lib/active_record/connection_adapters/abstract_adapter.rb:3:in `'
    4: from /data/data/com.termux/files/usr/lib/ruby/gems/2.6.0/gems/backports-3.11.4/lib/backports/std_lib.rb:9:in `require_with_backports'
    3: from /data/data/com.termux/files/usr/lib/ruby/gems/2.6.0/gems/backports-3.11.4/lib/backports/std_lib.rb:9:in `require'
    2: from /data/data/com.termux/files/usr/lib/ruby/2.6.0/bigdecimal/util.rb:9:in `'
    1: from /data/data/com.termux/files/usr/lib/ruby/gems/2.6.0/gems/backports-3.11.4/lib/backports/std_lib.rb:9:in `require_with_backports'
    /data/data/com.termux/files/usr/lib/ruby/gems/2.6.0/gems/backports-3.11.4/lib/backports/std_lib.rb:9:in `require': dlopen failed: cannot locate symbol "rmpd_util_str_to_d" referenced by "/data/data/com.termux/files/usr/lib/ruby/2.6.0/aarch64-linux-android/bigdecimal/util.so"... - /data/data/com.termux/files/usr/lib/ruby/2.6.0/aarch64-linux-android/bigdecimal/util.so (LoadError)
    19: from ./msfconsole:48:in `'
    18: from ./msfconsole:48:in `require'
    17: from /data/data/com.termux/files/home/metasploit-framework/lib/msf/core/payload_generator.rb:2:in `'
    16: from /data/data/com.termux/files/home/metasploit-framework/lib/msf/data/data/com.termux/files/usr/lib/ruby/gems/2.6.0/gems/backports-3.11.4/lib/backports/std_lib.rb:9:in `require'
    6: from /data/data/com.termux/files/usr/lib/ruby/gems/2.6.0/gems/backports-3.11.4/lib/backports/std_lib.rb:9:in `require'
    5: from /data/data/com.termux/files/home/metasploit-framework/lib/msf/core/db_manager.rb:23:in `'
    4: from /data/data/com.termux/files/home/metasploit-framework/lib/msf/core/db_manager.rb:61:in `'
    3: from /data/data/com.termux/files/home/metasploit-framework/lib/metasploit/framework/require.rb:115:in `optionally_include_metasploit_credential_creation'
    2: from /data/data/com.termux/files/home/metasploit-framework/lib/metasploit/framework/require.rb:68:in `optionally_include_metasploit_credential_creation'
    1: from /data/data/com.termux/files/home/metasploit-framework/lib/metasploit/framework/require.rb:20:in `optionally'
    /data/data/com.termux/files/home/metasploit-framework/lib/metasploit/framework/require.rb:25:in `rescue in optionally': undefined method `without' for # (NoMethodError)
    $

    ReplyDelete
  48. And bro plz give your whatsapp no show that i can send the screenshot of error. plz bro help me yr it's urgent bro

    ReplyDelete
  49. msfconsole Traceback (most recent call last):
    ruby: no Ruby script found in input (LoadError)
    How to resolve

    ReplyDelete
  50. $ msfconsole Traceback (most recent call last):
    ruby: no Ruby script found in input (LoadError)
    How to resolve

    ReplyDelete
  51. ls
    $ ./msfconsole

    [!] There was an error parsing `Gemfile`:
    [!] There was an error while loading `grpc.gemspec`: cannot load such file -- grpc/version
    Does it try to require a relative path? That's been removed in Ruby 1.9. Bundler cannot continue.

    # from /data/data/com.termux/files/home/metasploit-framework/grpc.gemspec:4
    # -------------------------------------------
    # $LOAD_PATH.push File.expand_path('../src/ruby/lib', __FILE__)
    > require 'grpc/version'
    #
    # -------------------------------------------
    . Bundler cannot continue.

    # from /data/data/com.termux/files/home/metasploit-framework/Gemfile:4
    # -------------------------------------------
    # # spec.add_runtime_dependency '', []
    > gemspec name: 'metasploit-framework'
    #
    # -------------------------------------------





    Pls help brother Hariomg530@gmail.com

    ReplyDelete
  52. When i entered msfconsole it is shwoing that
    Could not find nokogiri-1.8.0 in any of the sources
    What should i do man ?

    ReplyDelete
  53. $ bundle install -j5
    Could not locate Gemfile?

    ReplyDelete